Debian 8 Upgrade to Debian 9: Key Error

There is no public key available for the following key IDs:
EF0F382A1A7B6500

If you’re getting an error like the above when attempting to upgrade to Debian 9 (the new Stable version), it’s an easy fix:

sudo apt-get install debian-keyring debian-archive-keyring

Complaints about keys scare me something chronic, as it can be a sign that the repo (or worse, your OS) has been compromised… so I always look for a way to solve it.

Fortunately this one was easy.

Leave a Reply

Your email address will not be published. Required fields are marked *